diff setup.py @ 0:1f85ed8ed469

Iniitial commit of sample ofxstatement plugin
author Andrey Lebedev <andrey@lebedev.lt>
date Sat, 02 Nov 2013 14:26:03 +0200
parents
children 2b39e0f9d465
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py	Sat Nov 02 14:26:03 2013 +0200
@@ -0,0 +1,40 @@
+#!/usr/bin/python3
+"""Setup
+"""
+from setuptools import find_packages
+from distutils.core import setup
+
+version = "0.0.1"
+
+with open('README.rst') as f:
+    long_description = f.read()
+
+setup(name='ofxstatement-sample',
+      version=version,
+      author="Andrey Lebedev",
+      author_email="andrey@lebedev.lt",
+      url="https://github.com/kedder/ofxstatement",
+      description=("Sample plugin for ofxstatement"),
+      long_description=long_description,
+      license="GPLv3",
+      keywords=["ofx", "banking", "statement"],
+      classifiers=[
+          'Development Status :: 3 - Alpha',
+          'Programming Language :: Python :: 3',
+          'Natural Language :: English',
+          'Topic :: Office/Business :: Financial :: Accounting',
+          'Topic :: Utilities',
+          'Environment :: Console',
+          'Operating System :: OS Independent',
+          'License :: OSI Approved :: GNU Affero General Public License v3'],
+      packages=find_packages('src'),
+      package_dir={'': 'src'},
+      namespace_packages=["ofxstatement", "ofxstatement.plugins"],
+      entry_points={
+          'ofxstatement':
+          ['sample = ofxstatement.plugins.sample:SamplePlugin']
+          },
+      install_requires=['ofxstatement'],
+      include_package_data=True,
+      zip_safe=True
+      )