diff setup.py @ 7:829eb62755b0

First cut at an HSBC (USA) plugin
author Louis Opter <kalessin@kalessin.fr>
date Thu, 17 Nov 2016 16:25:12 -0800
parents 2b39e0f9d465
children 28548158a325
line wrap: on
line diff
--- a/setup.py	Fri Aug 19 10:34:43 2016 +0300
+++ b/setup.py	Thu Nov 17 16:25:12 2016 -0800
@@ -1,40 +1,67 @@
-#!/usr/bin/python3
-"""Setup
-"""
-from setuptools import find_packages
-from distutils.core import setup
+# Copyright (c) 2016, Louis Opter <louis@opter.org>
+#
+# This file is part of ofxstatement-us-hsbc.
+#
+# ofxstatement-us-hsbc is free software: you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation, either version 3 of the
+# License, or (at your option) any later version.
+#
+# ofxstatement-us-hsbc is distributed in the hope that it will be
+# useful, but WITHOUT ANY WARRANTY; without even the implied warranty
+# of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program.  If not, see <http://www.gnu.org/licenses/>.
+
+import setuptools
 
 version = "0.0.1"
 
 with open('README.rst') as f:
     long_description = f.read()
 
-setup(name='ofxstatement-sample',
-      version=version,
-      author="Andrey Lebedev",
-      author_email="andrey@lebedev.lt",
-      url="https://github.com/kedder/ofxstatement",
-      description=("Sample plugin for ofxstatement"),
-      long_description=long_description,
-      license="GPLv3",
-      keywords=["ofx", "banking", "statement"],
-      classifiers=[
-          'Development Status :: 3 - Alpha',
-          'Programming Language :: Python :: 3',
-          'Natural Language :: English',
-          'Topic :: Office/Business :: Financial :: Accounting',
-          'Topic :: Utilities',
-          'Environment :: Console',
-          'Operating System :: OS Independent',
-          'License :: OSI Approved :: GNU General Public License v3'],
-      packages=find_packages('src'),
-      package_dir={'': 'src'},
-      namespace_packages=["ofxstatement", "ofxstatement.plugins"],
-      entry_points={
-          'ofxstatement':
-          ['sample = ofxstatement.plugins.sample:SamplePlugin']
-          },
-      install_requires=['ofxstatement'],
-      include_package_data=True,
-      zip_safe=True
-      )
+setuptools.setup(
+    name='ofxstatement-us-hsbc',
+    version=version,
+    author="Louis Opter",
+    author_email="louis@opter.org",
+    url="https://github.com/lopter/ofxstatement",
+    description=("HSBC (USA) plugin for ofxstatement"),
+    long_description=long_description,
+    license="GPLv3",
+    keywords=["ofx", "banking", "statement", "hsbc", "plugin"],
+    classifiers=[
+        'Development Status :: 3 - Alpha',
+        'Programming Language :: Python :: 3.6',
+        'Natural Language :: English',
+        'Topic :: Office/Business :: Financial :: Accounting',
+        'Topic :: Utilities',
+        'Environment :: Console',
+        'Operating System :: OS Independent',
+        'License :: OSI Approved :: GNU General Public License v3'],
+    packages=setuptools.find_packages('src'),
+    package_dir={'': 'src'},
+    namespace_packages=["ofxstatement", "ofxstatement.plugins"],
+    entry_points={
+        'ofxstatement': [
+            'us-hsbc = ofxstatement.plugins.us_hsbc:HSBCUSAPlugin',
+        ]
+    },
+    install_requires=[
+        'ofxstatement',
+        'python-dateutil~=2.6.0',
+    ],
+    extras_require={
+        "dev": [
+            "flake8",
+            "mypy-lang",
+            "ipython",
+            "pdbpp",
+            "pep8",
+        ]
+    },
+    include_package_data=True,
+    zip_safe=True
+)