comparison PKGBUILD @ 4:5cc2087b8737

lightsd 0.9.2 lightsd now know how to drop privileges, so let's create an user/group for it. This allows us to integrate more nicely with systemd.
author Louis Opter <kalessin@kalessin.fr>
date Sun, 13 Sep 2015 18:38:36 -0700
parents 6bd6e467bb66
children 520fe381a4f5
comparison
equal deleted inserted replaced
3:6bd6e467bb66 4:5cc2087b8737
1 # Maintainer: Louis Opter <kalessin@kalessin.fr> 1 # Maintainer: Louis Opter <kalessin@kalessin.fr>
2 2
3 pkgname=lightsd 3 pkgname=lightsd
4 pkgver=0.9.1 4 pkgver=0.9.2
5 pkgrel=4 5 pkgrel=1
6 epoch=1 6 epoch=1
7 pkgdesc="Daemon to control your LIFX smart bulbs via a JSON-RPC API" 7 pkgdesc="Daemon to control your LIFX smart bulbs via a JSON-RPC API"
8 arch=("i686" "x86_64") 8 arch=("i686" "x86_64")
9 url="https://www.github.com/lopter/lightsd/" 9 url="https://www.github.com/lopter/lightsd/"
10 license=("GPL3") 10 license=("GPL3")
11 depends=("libevent>=2.0.19" "libbsd>=0.5.0") 11 depends=("libevent>=2.0.19")
12 optdepends=( 12 optdepends=(
13 "python: to run the interactive lightsc.py example client" 13 "python: to run the interactive lightsc.py example client"
14 "ipython: makes lightsc.py more user-friendly" 14 "ipython: makes lightsc.py more user-friendly"
15 ) 15 )
16 makedepends=("cmake>=2.8.11") 16 makedepends=("cmake>=2.8.11")
17 source=("https://github.com/lopter/lightsd/archive/${pkgver}.tar.gz") 17 source=("https://github.com/lopter/lightsd/archive/${pkgver}.tar.gz")
18 sha256sums=("72eba6074ed18609fb0caf7b7429e1b8f6c3564ca6f81357be22c06ac00956b6") 18 sha256sums=("2d785ede7c2e3b603ad33c11c3e44b5c634ee17e745d39296125025eddbbf420")
19 #source=("src/${pkgname}-${pkgver}::hg+file:///home/kal/projs/lightsd")
20 #sha256sums="SKIP"
21 install=lightsd.install
19 22
20 build() { 23 build() {
21 cd "$srcdir/$pkgname-$pkgver" 24 cd "$srcdir/$pkgname-$pkgver"
22 25
23 cmake \ 26 cmake . \
24 -DCMAKE_BUILD_TYPE=RELEASE \ 27 -DCMAKE_BUILD_TYPE=RELEASE \
25 -DCMAKE_INSTALL_PREFIX=/usr \ 28 -DCMAKE_INSTALL_PREFIX=/usr \
26 . 29 -DLGTD_RUNTIME_DIRECTORY=/run/lightsd
27 30
28 make 31 make
29 } 32 }
30 33
31 check() { 34 check() {