diff PKGBUILD @ 4:5cc2087b8737

lightsd 0.9.2 lightsd now know how to drop privileges, so let's create an user/group for it. This allows us to integrate more nicely with systemd.
author Louis Opter <kalessin@kalessin.fr>
date Sun, 13 Sep 2015 18:38:36 -0700
parents 6bd6e467bb66
children 520fe381a4f5
line wrap: on
line diff
--- a/PKGBUILD	Sat Sep 05 23:21:02 2015 -0700
+++ b/PKGBUILD	Sun Sep 13 18:38:36 2015 -0700
@@ -1,29 +1,32 @@
 # Maintainer: Louis Opter <kalessin@kalessin.fr>
 
 pkgname=lightsd
-pkgver=0.9.1
-pkgrel=4
+pkgver=0.9.2
+pkgrel=1
 epoch=1
 pkgdesc="Daemon to control your LIFX smart bulbs via a JSON-RPC API"
 arch=("i686" "x86_64")
 url="https://www.github.com/lopter/lightsd/"
 license=("GPL3")
-depends=("libevent>=2.0.19" "libbsd>=0.5.0")
+depends=("libevent>=2.0.19")
 optdepends=(
     "python: to run the interactive lightsc.py example client"
     "ipython: makes lightsc.py more user-friendly"
 )
 makedepends=("cmake>=2.8.11")
 source=("https://github.com/lopter/lightsd/archive/${pkgver}.tar.gz")
-sha256sums=("72eba6074ed18609fb0caf7b7429e1b8f6c3564ca6f81357be22c06ac00956b6")
+sha256sums=("2d785ede7c2e3b603ad33c11c3e44b5c634ee17e745d39296125025eddbbf420")
+#source=("src/${pkgname}-${pkgver}::hg+file:///home/kal/projs/lightsd")
+#sha256sums="SKIP"
+install=lightsd.install
 
 build() {
     cd "$srcdir/$pkgname-$pkgver"
 
-    cmake                           \
+    cmake .                         \
         -DCMAKE_BUILD_TYPE=RELEASE  \
         -DCMAKE_INSTALL_PREFIX=/usr \
-        .
+        -DLGTD_RUNTIME_DIRECTORY=/run/lightsd
 
     make
 }